aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-12 15:27:58 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-12 15:28:15 +0100
commit8592ae4096f3f9c2b08b87ad2fcbbbfadf75f2d7 (patch)
treea757c1d80ec77952eae2cc4de5d89c01f14760fc /tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt
parente7decc7637e9eb7e66a0d19705090f18488028c0 (diff)
parent14492ecee2e34843efd3ef070503a43a48552055 (diff)
Merge remote-tracking branch 'origin/wip/cmake' into dev
Conflicts: dependencies.yaml Change-Id: Ifff48b9d0e7962d481e63c49399e2d304e1011e5
Diffstat (limited to 'tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt b/tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt
new file mode 100644
index 0000000000..aeab9f84fa
--- /dev/null
+++ b/tests/auto/qml/qqmlmoduleplugin/plugin.2/childplugin/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from childplugin.pro.
+
+#####################################################################
+## childplugin Generic Library:
+#####################################################################
+
+qt_add_cmake_library(childplugin.2 # special case
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../../imports/org/qtproject/AutoTestQmlPluginType.2/ChildPlugin"
+ SOURCES
+ childplugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::Qml
+ Qt::QmlPrivate
+)
+
+#### Keys ignored in scope 1:.:.:childplugin.pro:<TRUE>:
+# IMPORT_DIR = "DESTDIR"
+# IMPORT_FILES = "qmldir"
+# TEMPLATE = "lib"
+
+# special case begin
+qt_autogen_tools_initial_setup(childplugin.2)
+set_target_properties(childplugin.2 PROPERTIES OUTPUT_NAME "childplugin")
+file(COPY qmldir
+ DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/../../imports/org/qtproject/AutoTestQmlPluginType.2/ChildPlugin"
+)
+# special case end