aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlpropertymap/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-10-11 13:55:03 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-10-14 08:49:58 +0000
commit31df3b6ced92197636e0b1f450631971bbf17cd2 (patch)
treea7c5bb05b40b363af4a52058ef580fcab62b44bf /tests/auto/qml/qqmlpropertymap/CMakeLists.txt
parent6a0bb9a7d6a6473920da74bb48c52a4eaed990b0 (diff)
Regenerate the necessary bits of qtdeclarative after wip/qt6 merge
Change-Id: If58c29baf7fa3c3591968fca6d11f7649308dbf9 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/qml/qqmlpropertymap/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlpropertymap/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/tests/auto/qml/qqmlpropertymap/CMakeLists.txt b/tests/auto/qml/qqmlpropertymap/CMakeLists.txt
index fc7da3df75..2daf727a5c 100644
--- a/tests/auto/qml/qqmlpropertymap/CMakeLists.txt
+++ b/tests/auto/qml/qqmlpropertymap/CMakeLists.txt
@@ -4,8 +4,13 @@
## tst_qqmlpropertymap Test:
#####################################################################
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ data/*)
+list(APPEND test_data ${test_data_glob})
+
add_qt_test(tst_qqmlpropertymap
- GUI
SOURCES
../../shared/util.cpp ../../shared/util.h
tst_qqmlpropertymap.cpp
@@ -20,17 +25,12 @@ add_qt_test(tst_qqmlpropertymap
Qt::Gui
Qt::Qml
Qt::Quick
+ TESTDATA ${test_data}
)
-#### Keys ignored in scope 1:.:.:qqmlpropertymap.pro:<TRUE>:
-# CONFIG = "testcase"
-
## Scopes:
#####################################################################
-#### Keys ignored in scope 2:.:.:qqmlpropertymap.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
-
extend_target(tst_qqmlpropertymap CONDITION ANDROID OR APPLE_IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"