aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/qquickanimators/CMakeLists.txt
diff options
context:
space:
mode:
authorShawn Rutledge <shawn.rutledge@qt.io>2020-10-19 21:11:22 +0200
committerShawn Rutledge <shawn.rutledge@qt.io>2020-10-22 06:53:42 +0200
commitec9d125f553c073ec7a431114a568eaeb6534b63 (patch)
treebd1fc3cd74c0f26c82c76136f39a0f27ef716abb /tests/auto/quick/qquickanimators/CMakeLists.txt
parentdac2c8aec4917742aed6e311cf542dc37da60809 (diff)
Update and activate tst_animators
Amends a0f8be4021caa9bb5055923f0eea3bee0e345235; it's not clear if there's any reason we haven't been running this test all these years. But we need to use testFileUrl() for loading QML files, and some additional updates make it more like the other tests. Regenerated CMakeLists.txt from the .pro files: python3 ~/dev/qt6/qtbase/util/cmake/pro2cmake.py *.pro Pick-to: 5.15 Change-Id: I3ddcc993c4536c2d4d751a37c0425943c7d86766 Reviewed-by: Mitch Curtis <mitch.curtis@qt.io>
Diffstat (limited to 'tests/auto/quick/qquickanimators/CMakeLists.txt')
-rw-r--r--tests/auto/quick/qquickanimators/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/auto/quick/qquickanimators/CMakeLists.txt b/tests/auto/quick/qquickanimators/CMakeLists.txt
index db1c18e03c..908a8158a6 100644
--- a/tests/auto/quick/qquickanimators/CMakeLists.txt
+++ b/tests/auto/quick/qquickanimators/CMakeLists.txt
@@ -4,16 +4,44 @@
## tst_qquickanimators Test:
#####################################################################
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ data/*)
+list(APPEND test_data ${test_data_glob})
+
qt_internal_add_test(tst_qquickanimators
SOURCES
+ ../../shared/util.cpp ../../shared/util.h
+ ../shared/geometrytestutil.cpp ../shared/geometrytestutil.h
+ ../shared/viewtestutil.cpp ../shared/viewtestutil.h
+ ../shared/visualtestutil.cpp ../shared/visualtestutil.h
tst_qquickanimators.cpp
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
+ INCLUDE_DIRECTORIES
+ ../../shared
PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
Qt::QmlPrivate
Qt::QuickPrivate
+ TESTDATA ${test_data}
)
+#### Keys ignored in scope 1:.:.:qquickanimators.pro:<TRUE>:
+# DISTFILES = "data/*"
+
## Scopes:
#####################################################################
+
+qt_internal_extend_target(tst_qquickanimators CONDITION ANDROID OR IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\":/data\\\"
+)
+
+qt_internal_extend_target(tst_qquickanimators CONDITION NOT ANDROID AND NOT IOS
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
+)