aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quickcontrols2/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2022-05-10 17:33:54 +0200
committerIvan Solovev <ivan.solovev@qt.io>2022-05-12 13:41:54 +0200
commit784a9b604cbe06179ac62e5a9a0892d37a0505c4 (patch)
tree1ae520e94af4203068b4c2f5d4bb9eea5715cb20 /tests/auto/quickcontrols2/CMakeLists.txt
parent199a8f7a0ec376e5fa7b0e8c02732ab6a0157909 (diff)
Android: fix tst_QQuickMenu
There were several reasons for the test failures: - Difference in default behavior on Android and Desktop systems. On Android the menus are not cascading by default, so some tests failed because they were expecting cascading menus. That is fixed by explicitly specifying cascade flag in QML files. - Mouse hovering does not open/close sub-menus on Android, because Android has no cursor support. So parts of the tests that rely on this behavior are simply skipped. Same for the parts of the tests that try to explicitly set cursor position. - Some of the tests expect certain window size. On Android calling QQuickWindow::show() shows the window fullscreen, which can be larger or smaller than an expected size. As a result the tests fail because various assumptions are broken. That is fixed by using showNormal(), which shows the window with the desired size. This makes little sense in real applications, because it can result in some information being "hidden" behind the screen border, but seems to be fine for tests. - The previously skipped tst_QQuickMenu::disableWhenTriggered() is now enabled, because it does not crash and needed just some minor adjustments. Fixes: QTBUG-100256 Change-Id: I53832f52071d5c2495a97058a968775d3f89598e Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Mitch Curtis <mitch.curtis@qt.io> (cherry picked from commit e2622964092f340dfdb95d97a40de99591520df0)
Diffstat (limited to 'tests/auto/quickcontrols2/CMakeLists.txt')
-rw-r--r--tests/auto/quickcontrols2/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/tests/auto/quickcontrols2/CMakeLists.txt b/tests/auto/quickcontrols2/CMakeLists.txt
index 0428406c79..5bd05b95ee 100644
--- a/tests/auto/quickcontrols2/CMakeLists.txt
+++ b/tests/auto/quickcontrols2/CMakeLists.txt
@@ -25,9 +25,7 @@ add_subdirectory(qquickiconlabel)
add_subdirectory(qquickimaginestyle)
add_subdirectory(qquickmaterialstyle)
add_subdirectory(qquickmaterialstyleconf)
-if(NOT ANDROID) # QTBUG-101005
add_subdirectory(qquickmenu)
-endif()
add_subdirectory(qquickmenubar)
add_subdirectory(qquickninepatchimage)
add_subdirectory(qquickpopup)