aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quicktest/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2021-01-29 15:50:39 +0100
committerFabian Kosmale <fabian.kosmale@qt.io>2021-02-01 18:19:24 +0100
commitedca9f3d60141a823a3b4401039f260c2c7f7888 (patch)
treed1c9161c31179894f4fd45bf4056bc382f3b53c7 /tests/auto/quicktest/CMakeLists.txt
parentf6fc35b45b449fe7aaca3237f29393a12fc3f90c (diff)
QuickTest: Do not recurse forever on inline components in enumerateTestCases
In TestCaseCollector::enumerateTestCases, we visit the super compilation unit of QML tpyes to check if they might be instances of TestCase. However, in the case of inline components, the super unit is the current compilation unit, and we would recurse endlessly. This does not address the issue that an inline component might actually inherit TestCase. However, as this only affects the enumeration output and does not actually affect test execution, this is not that much of an issue. It should also be noted that the enumeration also fails in any case where TestCases are loaded dynamically (with a loader), so the method is not 100% accurate even in the absence of inline components. Fixes: QTBUG-90740 Task-number: QTBUG-90762 Pick-to: 5.15 6.0 Change-Id: I7e133d62c4f62fc46e9bd3999ff755f7ded3c386 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'tests/auto/quicktest/CMakeLists.txt')
-rw-r--r--tests/auto/quicktest/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/quicktest/CMakeLists.txt b/tests/auto/quicktest/CMakeLists.txt
index 3686db8417..45c763eec9 100644
--- a/tests/auto/quicktest/CMakeLists.txt
+++ b/tests/auto/quicktest/CMakeLists.txt
@@ -4,3 +4,4 @@ add_subdirectory(polish)
add_subdirectory(signalspy)
add_subdirectory(quicktestmainwithsetup)
add_subdirectory(testfiltering)
+add_subdirectory(testswithcomponents)