aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/highdpi/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-08-07 16:25:52 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-08-14 14:01:58 +0000
commit4e14f6e70abb4a02a570a390f462736666b234a7 (patch)
treeabd6ccb232ab16eabe1b41e6e76435ad248fb766 /tests/manual/highdpi/CMakeLists.txt
parent494dc05ea1758f2bee49ddb98712a030336acbd2 (diff)
Add QtDeclarative Test Coverage
All tests compile and run on a developer build. These tests are failing: tst_qqmlsqldatabase Fails due to missing sql driver tst_qqmlsqldatabase Fails in wip/qt6 tst_ququicklayouts Fails in wip/qt6 tst_flickableinterop Fails in wip/qt6 tst_qquickpinchandler Fails in wip/qt6 tst_qquickflickable Fails in wip/qt6 tst_qquickgridview Fails in wip/qt6 tst_qquickimage Fails due to missing jpeg plugin tst_qquicklistview Fails in wip/qt6 tst_qquicktext Fails in wip/qt6 tst_qquickcanvasitem Fails in wip/qt6 tst_scenegraph Fails due to missing jpeg plugin tst_TestFiltering Fails in wip/qt6 Change-Id: I4b9d69c118e23c095cb72ad5a67653fc30943bb1 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/manual/highdpi/CMakeLists.txt')
-rw-r--r--tests/manual/highdpi/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/manual/highdpi/CMakeLists.txt b/tests/manual/highdpi/CMakeLists.txt
new file mode 100644
index 0000000000..bbd01613c7
--- /dev/null
+++ b/tests/manual/highdpi/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from highdpi.pro.
+
+#####################################################################
+## qmlimageproviderplugin Plugin:
+#####################################################################
+
+add_qt_plugin(qmlimageproviderplugin
+ OUTPUT_DIRECTORY "ImageProvider"
+ SOURCES
+ imageprovider.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:highdpi.pro:<TRUE>:
+# CONFIG = "plugin"
+# INSTALLS = "target" "qml"
+# TEMPLATE = "lib"
+# qml.files = "ImageProvider/qmldir"
+# qml.path = "$$[QT_INSTALL_EXAMPLES]/quick/imageprovider/ImageProvider"
+# target.path = "$$[QT_INSTALL_EXAMPLES]/quick/imageprovider/ImageProvider"