aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/highdpi/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 11:39:42 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-15 12:24:38 +0000
commit91e32f86b53bb930405a58e19c84746ee85cdf89 (patch)
tree3419986b62355e718551b83a514c1169480a8ed0 /tests/manual/highdpi/CMakeLists.txt
parent387f360b3b2634094889478f2b258e65a70b9aa6 (diff)
Regenerate remaining tests to be in sync
Change-Id: I200c8f58ad13bc1bc78409a3ce49348584ba5b51 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/manual/highdpi/CMakeLists.txt')
-rw-r--r--tests/manual/highdpi/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/tests/manual/highdpi/CMakeLists.txt b/tests/manual/highdpi/CMakeLists.txt
index bbd01613c7..13d2d9e189 100644
--- a/tests/manual/highdpi/CMakeLists.txt
+++ b/tests/manual/highdpi/CMakeLists.txt
@@ -1,10 +1,12 @@
# Generated from highdpi.pro.
#####################################################################
-## qmlimageproviderplugin Plugin:
+## qmlimageproviderplugin Generic Library:
#####################################################################
-add_qt_plugin(qmlimageproviderplugin
+add_cmake_library(qmlimageproviderplugin
+ MODULE
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/quick/imageprovider/ImageProvider"
OUTPUT_DIRECTORY "ImageProvider"
SOURCES
imageprovider.cpp
@@ -16,9 +18,10 @@ add_qt_plugin(qmlimageproviderplugin
)
#### Keys ignored in scope 1:.:.:highdpi.pro:<TRUE>:
-# CONFIG = "plugin"
# INSTALLS = "target" "qml"
# TEMPLATE = "lib"
# qml.files = "ImageProvider/qmldir"
# qml.path = "$$[QT_INSTALL_EXAMPLES]/quick/imageprovider/ImageProvider"
# target.path = "$$[QT_INSTALL_EXAMPLES]/quick/imageprovider/ImageProvider"
+
+qt_autogen_tools_initial_setup(qmlimageproviderplugin)