aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/nodetypes_ng/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-08-07 16:25:52 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-08-14 14:01:58 +0000
commit4e14f6e70abb4a02a570a390f462736666b234a7 (patch)
treeabd6ccb232ab16eabe1b41e6e76435ad248fb766 /tests/manual/nodetypes_ng/CMakeLists.txt
parent494dc05ea1758f2bee49ddb98712a030336acbd2 (diff)
Add QtDeclarative Test Coverage
All tests compile and run on a developer build. These tests are failing: tst_qqmlsqldatabase Fails due to missing sql driver tst_qqmlsqldatabase Fails in wip/qt6 tst_ququicklayouts Fails in wip/qt6 tst_flickableinterop Fails in wip/qt6 tst_qquickpinchandler Fails in wip/qt6 tst_qquickflickable Fails in wip/qt6 tst_qquickgridview Fails in wip/qt6 tst_qquickimage Fails due to missing jpeg plugin tst_qquicklistview Fails in wip/qt6 tst_qquicktext Fails in wip/qt6 tst_qquickcanvasitem Fails in wip/qt6 tst_scenegraph Fails due to missing jpeg plugin tst_TestFiltering Fails in wip/qt6 Change-Id: I4b9d69c118e23c095cb72ad5a67653fc30943bb1 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/manual/nodetypes_ng/CMakeLists.txt')
-rw-r--r--tests/manual/nodetypes_ng/CMakeLists.txt60
1 files changed, 60 insertions, 0 deletions
diff --git a/tests/manual/nodetypes_ng/CMakeLists.txt b/tests/manual/nodetypes_ng/CMakeLists.txt
new file mode 100644
index 0000000000..8666cd15bc
--- /dev/null
+++ b/tests/manual/nodetypes_ng/CMakeLists.txt
@@ -0,0 +1,60 @@
+# Generated from nodetypes_ng.pro.
+
+#####################################################################
+## nodetypes_ng Binary:
+#####################################################################
+
+add_qt_executable(nodetypes_ng
+ GUI
+ SOURCES
+ nodetypes_ng.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+add_qt_resource(nodetypes_ng "nodetypes_ng"
+ PREFIX
+ "/"
+ FILES
+ AtlasedImages.qml
+ CompressedImages.qml
+ DistanceFieldText.qml
+ Images.qml
+ Layers.qml
+ LotsOfNodes.qml
+ LotsOfRects.qml
+ MoreWindows.qml
+ MultiClipRects.qml
+ Painter.qml
+ Rects.qml
+ ShaderEffect.qml
+ ShaderEffectNoAnim.qml
+ ShaderEffectSource.qml
+ SimpleRect.qml
+ Text.qml
+ arrow-down.png
+ arrow-up.png
+ blacknwhite.png
+ car_etc2_nomips.ktx
+ face-smile.png
+ main.qml
+ minus-sign.png
+ plus-sign.png
+ qt.png
+ qt_bc1_10mips.ktx
+ shadow_pass1.frag.qsb
+ shadow_pass1_legacy_gl.frag
+ shadow_pass2.frag.qsb
+ shadow_pass2_legacy_gl.frag
+ wobble.frag.qsb
+ wobble.vert.qsb
+ wobble_legacy_gl.frag
+ wobble_legacy_gl.vert
+)
+
+
+#### Keys ignored in scope 1:.:.:nodetypes_ng.pro:<TRUE>:
+# OTHER_FILES = "main.qml" "SimpleRect.qml" "Rects.qml" "LotsOfRects.qml"