aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/quickcontrols/nativestyle/CMakeLists.txt
diff options
context:
space:
mode:
authorMitch Curtis <mitch.curtis@qt.io>2022-11-18 15:15:16 +0800
committerMitch Curtis <mitch.curtis@qt.io>2022-12-01 10:26:20 +0800
commit4bd87b903b355b53e3105ba1ae7c154c4e55cdaf (patch)
treecc2edb597f0d5871302eb86e9dda78217384a5aa /tests/manual/quickcontrols/nativestyle/CMakeLists.txt
parent786e1748d4469c135a922a221024f3f9c421c0de (diff)
Remove "2" from Qt Quick Controls directories
Qt Quick Controls 2 was named that way because it was a follow-up to Qt Quick Controls 1.x. Now that Qt Quick Controls 1 is no longer supported, we don't need to have "2" in the name. Work on this was already started for the documentation in 1abdfe5d5a052f2298b7bf657513dfa7e0c66a56. By doing this renaming a few weeks before feature freeze, it won't affect the release but still results in as little time possible spent manually fixing conflicts in cherry-picks from non-LTS releases as a result of the renaming. This patch does the following: - Renames directories. - Adapts CMakeLists.txt and other files to account for the new paths. A follow-up patch will handle documentation. It does not touch library names or other user-facing stuff, as that will have to be done in Qt 7. Task-number: QTBUG-95413 Change-Id: I170d8db19033ee71e495ff0c5c1a517a41ed7634 Reviewed-by: Mitch Curtis <mitch.curtis@qt.io>
Diffstat (limited to 'tests/manual/quickcontrols/nativestyle/CMakeLists.txt')
-rw-r--r--tests/manual/quickcontrols/nativestyle/CMakeLists.txt87
1 files changed, 87 insertions, 0 deletions
diff --git a/tests/manual/quickcontrols/nativestyle/CMakeLists.txt b/tests/manual/quickcontrols/nativestyle/CMakeLists.txt
new file mode 100644
index 0000000000..0f4e30bd53
--- /dev/null
+++ b/tests/manual/quickcontrols/nativestyle/CMakeLists.txt
@@ -0,0 +1,87 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# Generated from desktopgallery.pro.
+# special case skip regeneration
+# Remove the skip, after somebody figures out if this is supposed
+# to be a manual test, or a full-blown project like it is now
+# because it was copied over from an example.
+
+cmake_minimum_required(VERSION 3.16)
+project(desktopgallery LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quickcontrols2/desktopgallery")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS QuickControls2)
+
+qt_add_executable(desktopgallery
+ main.cpp
+)
+target_link_libraries(desktopgallery PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Quick
+ Qt::QuickControls2
+)
+
+
+# Resources:
+set(qmake_immediate_resource_files
+ "Buttons.qml"
+ "CheckBoxes.qml"
+ "ComboBoxes.qml"
+ "ControlContainer.qml"
+ "CustomButtons.qml"
+ "CustomCheckBoxes.qml"
+ "CustomComboBoxes.qml"
+ "CustomDials.qml"
+ "CustomFrames.qml"
+ "CustomProgressBars.qml"
+ "CustomRadioButtons.qml"
+ "CustomScrollBars.qml"
+ "CustomSliders.qml"
+ "CustomSpinBoxes.qml"
+ "CustomTextAreas.qml"
+ "CustomTextFields.qml"
+ "Dials.qml"
+ "Frames.qml"
+ "ProgressBars.qml"
+ "RadioButtons.qml"
+ "ScrollBars.qml"
+ "Sliders.qml"
+ "SlidersMini.qml"
+ "SlidersSmall.qml"
+ "SpinBoxes.qml"
+ "TextAreas.qml"
+ "TextFields.qml"
+ "checkbox-icon.png"
+ "checkbox-icon16.png"
+ "checkbox-icon@2x.png"
+ "main.qml"
+)
+
+qt6_add_resources(desktopgallery "qmake_immediate"
+ PREFIX
+ "/"
+ FILES
+ ${qmake_immediate_resource_files}
+)
+
+install(TARGETS desktopgallery
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)