aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/tableview/tablemodel/form/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-08-07 16:25:52 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-08-14 14:01:58 +0000
commit4e14f6e70abb4a02a570a390f462736666b234a7 (patch)
treeabd6ccb232ab16eabe1b41e6e76435ad248fb766 /tests/manual/tableview/tablemodel/form/CMakeLists.txt
parent494dc05ea1758f2bee49ddb98712a030336acbd2 (diff)
Add QtDeclarative Test Coverage
All tests compile and run on a developer build. These tests are failing: tst_qqmlsqldatabase Fails due to missing sql driver tst_qqmlsqldatabase Fails in wip/qt6 tst_ququicklayouts Fails in wip/qt6 tst_flickableinterop Fails in wip/qt6 tst_qquickpinchandler Fails in wip/qt6 tst_qquickflickable Fails in wip/qt6 tst_qquickgridview Fails in wip/qt6 tst_qquickimage Fails due to missing jpeg plugin tst_qquicklistview Fails in wip/qt6 tst_qquicktext Fails in wip/qt6 tst_qquickcanvasitem Fails in wip/qt6 tst_scenegraph Fails due to missing jpeg plugin tst_TestFiltering Fails in wip/qt6 Change-Id: I4b9d69c118e23c095cb72ad5a67653fc30943bb1 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/manual/tableview/tablemodel/form/CMakeLists.txt')
-rw-r--r--tests/manual/tableview/tablemodel/form/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/tests/manual/tableview/tablemodel/form/CMakeLists.txt b/tests/manual/tableview/tablemodel/form/CMakeLists.txt
new file mode 100644
index 0000000000..5de4ae68b7
--- /dev/null
+++ b/tests/manual/tableview/tablemodel/form/CMakeLists.txt
@@ -0,0 +1,40 @@
+# Generated from form.pro.
+
+#####################################################################
+## form Binary:
+#####################################################################
+
+add_qt_executable(form
+ GUI
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+add_qt_resource(form "qmake_immediate"
+ PREFIX
+ "/"
+ FILES
+ RowForm.qml
+ main.qml
+)
+
+
+#### Keys ignored in scope 1:.:.:form.pro:<TRUE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:form.pro:QNX:
+# target.path = "/tmp/$${TARGET}/bin"
+
+#### Keys ignored in scope 4:.:.:form.pro:UNIX AND NOT ANDROID:
+# target.path = "/opt/$${TARGET}/bin"
+
+#### Keys ignored in scope 5:.:.:form.pro:NOT target.path_ISEMPTY:
+# INSTALLS = "target"