aboutsummaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorTasuku Suzuki <tasuku.suzuki@signal-slot.co.jp>2021-04-15 14:27:38 +0900
committerTasuku Suzuki <tasuku.suzuki@signal-slot.co.jp>2021-04-16 21:29:55 +0900
commit0a14cf7a06ca4aef59e55b5b2603b7aba8d84717 (patch)
treeabe567245904673156b857a709654a62ce17201c /tools/CMakeLists.txt
parent940376f564a0e36229d9aea543d33fb5de3e72b7 (diff)
Fix build without features.mainwindow
Change-Id: I497207567fe940bc077804b58db79bc5d44ae9f0 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 7668361005..fba5bd8457 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -35,7 +35,7 @@ endif()
if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_process AND QT_FEATURE_regularexpression AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT rtems)
add_subdirectory(qmlplugindump)
endif()
-if(QT_FEATURE_dialogbuttonbox AND QT_FEATURE_thread AND TARGET Qt::Quick AND TARGET Qt::Widgets AND NOT ANDROID AND NOT WASM AND NOT rtems)
+if(QT_FEATURE_mainwindow AND QT_FEATURE_dialogbuttonbox AND QT_FEATURE_thread AND TARGET Qt::Quick AND TARGET Qt::Widgets AND NOT ANDROID AND NOT WASM AND NOT rtems)
add_subdirectory(qmleasing)
endif()
if(QT_FEATURE_thread AND TARGET Qt::QuickTest AND NOT ANDROID AND NOT WASM AND NOT rtems)