aboutsummaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-10-27 16:56:51 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-11-09 11:46:51 +0100
commit32bd6ba7e9f854f5e9b0e6e0b5bd3bc23b4668d4 (patch)
tree67f95fb6dfd9f5d43107c9e7dd40046d579f8354 /tools/CMakeLists.txt
parent3bb72d31fc18b031bc823d80fec91ee3351d25a2 (diff)
CMake: Don't build Qt apps using Ninja when targeting iOS
Building them using ninja is pointless because they can't deployed / executed without the Xcode generator. Apart from that, the qml app will also fail to link in a static top-level build with Undefined symbols for architecture arm64: "_qt_main_wrapper", referenced from: implicit entry/start for main executable due to QTBUG-98058. The linking failure does not happen in CI because it does per-repo builds and not top-level builds. Amends 3e2a85384b1f5454e51a27827114e49746f8837a Pick-to: 6.2 Fixes: QTBUG-98015 Task-number: QTBUG-98058 Change-Id: I7fe6538ac0e2f2ea0f89b09bb1b77265a3cd51fe Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 5775a82f2b..1b7b4641d1 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -21,16 +21,16 @@ if(QT_FEATURE_qml_devtools AND QT_FEATURE_xmlstreamwriter)
# add_subdirectory(qmlcachegen)
# special case end
endif()
-if(QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND NOT rtems)
+if(QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND NOT IOS AND NOT rtems)
add_subdirectory(qml)
endif()
if(QT_FEATURE_qml_profiler AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND NOT rtems)
add_subdirectory(qmlprofiler)
endif()
-if(QT_FEATURE_qml_preview AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND NOT rtems)
+if(QT_FEATURE_qml_preview AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND NOT IOS AND NOT rtems)
add_subdirectory(qmlpreview)
endif()
-if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT rtems)
+if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT IOS AND NOT rtems)
add_subdirectory(qmlscene)
add_subdirectory(qmltime)
endif()