aboutsummaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2022-06-02 12:21:37 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2022-06-15 15:50:25 +0200
commitc701ed8b2f161ad8a82b7a4afd8bc5205a1e2fd0 (patch)
tree9b223828de3c31d10b5e2a94ab0f044d40532eeb /tools/CMakeLists.txt
parent38027eb7898ddf5af9a41807255fcf28d3323479 (diff)
CMake: Turn qmlls into an app instead of a tool as a workaround
A developer can have a host Qt without a qmlls, but still want to cross-compile Qt including all tools (the Yocto SDK scenario). While configuring the target Qt, they would get Searching for tool 'Qt6::qmlls' in package Qt6QmlTools. CMake Error at qtbase/cmake/QtToolHelpers.cmake:170 (message): The tool "Qt6::qmlls" was not found in the Qt6QmlTools package. Package found: 1 qmlls does not contribute to the Qt build itself (like moc or other code generators), so a host qmlls is not required to build a target Qt. But qt_internal_add_tool currently does not support not requiring the host tool when cross-building it. Work around this by building qmlls with qt_internal_add_app. Place it in libexec because it's not user facing and don't cross-compile it for platforms that don't support the SDK scenario. Task-number: QTBUG-100047 Change-Id: I4678ea791b21ecf3a57ccc870b9a4be09e2a8950 Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io> (cherry picked from commit 399cdef52bc921356458897b37c0682e255a66fc)
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 48545ff2d2..2e7a5273b6 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -6,7 +6,8 @@ if(QT_FEATURE_qml_devtools)
add_subdirectory(qmlimportscanner)
add_subdirectory(qmlformat)
add_subdirectory(qmltc)
- if (TARGET Qt::LanguageServerPrivate)
+ if (TARGET Qt::LanguageServerPrivate
+ AND NOT WASM AND NOT IOS AND NOT ANDROID AND NOT QNX AND NOT INTEGRITY AND NOT WEBOS)
add_subdirectory(qmlls)
endif()
endif()