aboutsummaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-03-16 10:17:18 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2021-03-19 14:57:46 +0100
commit5851195c4f8ea56d4641b5f1b68c7b79c4eca0fd (patch)
treedd10604e423a3349c79c43d22405d4fa9c2a09b7 /tools/CMakeLists.txt
parent6ddb78735b943b0563315140c6717d523bca2f76 (diff)
Add qmltypes for JavaScript root object
This change adds jsroot.qmltypes which represents QJSEngine's global / root object and a tool to generate it (qmlsjrootgen). If you wish to regenerate jsroot.qmltypes run the following commands: qmljsrootgen jsroot.json qmltyperegistrar jsroot.json --generate-qmltypes src/imports/builtins/jsroot.qmltypes --import-name QJSEngine --major-version 1 --minor-version 0 Fixes: QTBUG-90807 Change-Id: I5ba0a048586d2dd945009d65c2b51be8ead85feb Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 8438e8c6fa..7668361005 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -44,3 +44,6 @@ endif()
if(QT_FEATURE_private_tests AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND NOT rtems)
add_subdirectory(qmljs)
endif()
+if (QT_FEATURE_private_tests AND NOT ANDROID AND NOT WASM AND NOT rtems)
+ add_subdirectory(qmljsrootgen)
+endif()