aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmlcachegen/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-10-01 12:40:01 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-10-05 14:58:32 +0200
commit767dd738d3de9306062707fe05d32c91ed755da3 (patch)
treeebadcc9809322d5d78ce28f9b82bad1db949f232 /tools/qmlcachegen/CMakeLists.txt
parente7d90fc5268cdca6aa10f422f00ad4a0049ea157 (diff)
Long live libQtQmlCompiler!
Move all the code from tools/shared into src/qmlcompiler and build a static library from it so that we can re-use it in external tools. Change-Id: I7c8d8e59063dc7c711f4072f103a01095e6f5997 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'tools/qmlcachegen/CMakeLists.txt')
-rw-r--r--tools/qmlcachegen/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/tools/qmlcachegen/CMakeLists.txt b/tools/qmlcachegen/CMakeLists.txt
index 8cbe8dcfac..a509166dee 100644
--- a/tools/qmlcachegen/CMakeLists.txt
+++ b/tools/qmlcachegen/CMakeLists.txt
@@ -9,16 +9,14 @@ qt_add_tool(${target_name}
TARGET_DESCRIPTION "QML Cache Generator"
TOOLS_TARGET Qml # special case
SOURCES
- ../shared/resourcefilemapper.cpp ../shared/resourcefilemapper.h
generateloader.cpp
qmlcachegen.cpp
resourcefilter.cpp
DEFINES
QT_NO_CAST_FROM_ASCII
QT_NO_CAST_TO_ASCII
- INCLUDE_DIRECTORIES
- ../shared
PUBLIC_LIBRARIES
+ Qt::QmlCompilerPrivate
Qt::QmlDevToolsPrivate
)