aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmlimportscanner
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-06-05 17:02:52 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-06-08 08:22:42 +0000
commit5a3e668533450e82d0159596e5c24e738905f5f7 (patch)
tree87e769d1cd0f6c6d9e83d309eebab46ad634ece8 /tools/qmlimportscanner
parentf6f5687032bd6451e52c9ef221fb6a8a5b194389 (diff)
Port the declarative tools
Also fix up QmlDevTools module to not depend on QtQml, but instead make it include the headers / cpp files as it is done in the qmake project. Change-Id: I240c52d5357db150a7c0c819892fb0a3708ceee4 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tools/qmlimportscanner')
-rw-r--r--tools/qmlimportscanner/.prev_CMakeLists.txt22
-rw-r--r--tools/qmlimportscanner/CMakeLists.txt23
2 files changed, 45 insertions, 0 deletions
diff --git a/tools/qmlimportscanner/.prev_CMakeLists.txt b/tools/qmlimportscanner/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..9400878c15
--- /dev/null
+++ b/tools/qmlimportscanner/.prev_CMakeLists.txt
@@ -0,0 +1,22 @@
+# Generated from qmlimportscanner.pro.
+
+#####################################################################
+## qmlimportscanner Tool:
+#####################################################################
+
+add_qt_tool(qmlimportscanner
+ SOURCES
+ main.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::QmlDevToolsPrivate
+ PUBLIC_LIBRARIES
+ Qt::QmlDevTools
+)
+
+#### Keys ignored in scope 1:.:.:qmlimportscanner.pro:<TRUE>:
+# QMAKE_TARGET_DESCRIPTION = "QML" "Import" "Scanner"
+# _LOADED = "qt_tool"
+# _OPTION = "host_build"
diff --git a/tools/qmlimportscanner/CMakeLists.txt b/tools/qmlimportscanner/CMakeLists.txt
new file mode 100644
index 0000000000..8bd1191b82
--- /dev/null
+++ b/tools/qmlimportscanner/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from qmlimportscanner.pro.
+
+#####################################################################
+## qmlimportscanner Tool:
+#####################################################################
+
+add_qt_tool(qmlimportscanner
+ TOOLS_TARGET Qml # special case
+ SOURCES
+ main.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::QmlDevToolsPrivate
+ PUBLIC_LIBRARIES
+ Qt::QmlDevTools
+)
+
+#### Keys ignored in scope 1:.:.:qmlimportscanner.pro:<TRUE>:
+# QMAKE_TARGET_DESCRIPTION = "QML" "Import" "Scanner"
+# _LOADED = "qt_tool"
+# _OPTION = "host_build"