aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmlimportscanner
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-13 19:07:06 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 10:22:26 +0000
commite9cac99f3796740ea93b23b0fe893fc880e0b5d4 (patch)
tree7bb8d41c520e9d59bd2a39cf53ab8c948db57511 /tools/qmlimportscanner
parent82525a2b3861ad695c156c2cac4239134f8ac922 (diff)
Regenerate projects
Change-Id: I38044c382e4d84b5865a19cdd04cc8922bd72a77 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tools/qmlimportscanner')
-rw-r--r--tools/qmlimportscanner/.prev_CMakeLists.txt55
-rw-r--r--tools/qmlimportscanner/CMakeLists.txt55
2 files changed, 108 insertions, 2 deletions
diff --git a/tools/qmlimportscanner/.prev_CMakeLists.txt b/tools/qmlimportscanner/.prev_CMakeLists.txt
index 9400878c15..cdaf3b8bbe 100644
--- a/tools/qmlimportscanner/.prev_CMakeLists.txt
+++ b/tools/qmlimportscanner/.prev_CMakeLists.txt
@@ -17,6 +17,59 @@ add_qt_tool(qmlimportscanner
)
#### Keys ignored in scope 1:.:.:qmlimportscanner.pro:<TRUE>:
+# CMAKE_BIN_DIR = "$$cmakeRelativePath($$[QT_HOST_BINS], $$[QT_INSTALL_PREFIX])"
+# CMAKE_DEBUG_TYPE = <EMPTY>
+# CMAKE_QML_DIR = "$$cmakeRelativePath($$[QT_INSTALL_QML/get], $$[QT_INSTALL_PREFIX])"
+# CMAKE_QML_PLUGIN_SUFFIX_RELEASE = <EMPTY>
+# CMAKE_RELEASE_TYPE = <EMPTY>
+# QMAKE_SUBSTITUTES = "cmake_config_file"
# QMAKE_TARGET_DESCRIPTION = "QML" "Import" "Scanner"
-# _LOADED = "qt_tool"
# _OPTION = "host_build"
+# cmake_build_integration.files = "$$cmake_config_file.output" "$$PWD/Qt5QmlImportScannerTemplate.cpp.in"
+# cmake_build_integration.path = "$$[QT_INSTALL_LIBS]/cmake/Qt5QmlImportScanner"
+# cmake_config_file.input = "$$PWD/Qt5QmlImportScannerConfig.cmake.in"
+# cmake_config_file.output = "$$MODULE_BASE_OUTDIR/lib/cmake/Qt5QmlImportScanner/Qt5QmlImportScannerConfig.cmake"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qmlimportscanner.pro:CMAKE_BIN_DIR___contains___^\\.\\./._x_:
+# CMAKE_BIN_DIR = "$$[QT_HOST_BINS]/"
+# CMAKE_BIN_DIR_IS_ABSOLUTE = "True"
+
+#### Keys ignored in scope 3:.:.:qmlimportscanner.pro:CMAKE_QML_DIR___contains___^\\.\\./._x_:
+# CMAKE_QML_DIR = "$$[QT_INSTALL_QML/get]/"
+# CMAKE_QML_DIR_IS_ABSOLUTE = "True"
+
+#### Keys ignored in scope 4:.:.:qmlimportscanner.pro:static OR staticlib:
+# CMAKE_STATIC_TYPE = "true"
+
+#### Keys ignored in scope 5:.:.:qmlimportscanner.pro:WIN32:
+# CMAKE_QML_PLUGIN_SUFFIX_DEBUG = "d"
+
+#### Keys ignored in scope 7:.:.:qmlimportscanner.pro:APPLE:
+# CMAKE_QML_PLUGIN_SUFFIX_DEBUG = "_debug"
+
+#### Keys ignored in scope 8:.:.:qmlimportscanner.pro:else:
+# CMAKE_QML_PLUGIN_SUFFIX_DEBUG = <EMPTY>
+
+#### Keys ignored in scope 9:.:.:qmlimportscanner.pro:( QT_FEATURE_debug_and_release OR QT_CONFIG___contains___debug,debug OR release ):
+# CMAKE_DEBUG_TYPE = "debug"
+
+#### Keys ignored in scope 10:.:.:qmlimportscanner.pro:( QT_FEATURE_debug_and_release OR QT_CONFIG___contains___release,debug OR release ):
+# CMAKE_RELEASE_TYPE = "release"
+
+#### Keys ignored in scope 11:.:.:qmlimportscanner.pro:QT_FEATURE_debug_and_release:
+# CMAKE_DEBUG_AND_RELEASE = "TRUE"
+
+#### Keys ignored in scope 12:.:.:qmlimportscanner.pro:else:
+# CMAKE_DEBUG_AND_RELEASE = "FALSE"
+
+#### Keys ignored in scope 13:.:.:qmlimportscanner.pro:QMAKE_HOST.os___equals___Windows:
+# CMAKE_BIN_SUFFIX = ".exe"
+
+#### Keys ignored in scope 14:.:.:qmlimportscanner.pro:prefix_build:
+# INSTALLS = "cmake_build_integration"
+
+#### Keys ignored in scope 15:.:.:qmlimportscanner.pro:else:
+# COPIES = "cmake_build_integration"
diff --git a/tools/qmlimportscanner/CMakeLists.txt b/tools/qmlimportscanner/CMakeLists.txt
index 8bd1191b82..05f8837880 100644
--- a/tools/qmlimportscanner/CMakeLists.txt
+++ b/tools/qmlimportscanner/CMakeLists.txt
@@ -18,6 +18,59 @@ add_qt_tool(qmlimportscanner
)
#### Keys ignored in scope 1:.:.:qmlimportscanner.pro:<TRUE>:
+# CMAKE_BIN_DIR = "$$cmakeRelativePath($$[QT_HOST_BINS], $$[QT_INSTALL_PREFIX])"
+# CMAKE_DEBUG_TYPE = <EMPTY>
+# CMAKE_QML_DIR = "$$cmakeRelativePath($$[QT_INSTALL_QML/get], $$[QT_INSTALL_PREFIX])"
+# CMAKE_QML_PLUGIN_SUFFIX_RELEASE = <EMPTY>
+# CMAKE_RELEASE_TYPE = <EMPTY>
+# QMAKE_SUBSTITUTES = "cmake_config_file"
# QMAKE_TARGET_DESCRIPTION = "QML" "Import" "Scanner"
-# _LOADED = "qt_tool"
# _OPTION = "host_build"
+# cmake_build_integration.files = "$$cmake_config_file.output" "$$PWD/Qt5QmlImportScannerTemplate.cpp.in"
+# cmake_build_integration.path = "$$[QT_INSTALL_LIBS]/cmake/Qt5QmlImportScanner"
+# cmake_config_file.input = "$$PWD/Qt5QmlImportScannerConfig.cmake.in"
+# cmake_config_file.output = "$$MODULE_BASE_OUTDIR/lib/cmake/Qt5QmlImportScanner/Qt5QmlImportScannerConfig.cmake"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qmlimportscanner.pro:CMAKE_BIN_DIR___contains___^\\.\\./._x_:
+# CMAKE_BIN_DIR = "$$[QT_HOST_BINS]/"
+# CMAKE_BIN_DIR_IS_ABSOLUTE = "True"
+
+#### Keys ignored in scope 3:.:.:qmlimportscanner.pro:CMAKE_QML_DIR___contains___^\\.\\./._x_:
+# CMAKE_QML_DIR = "$$[QT_INSTALL_QML/get]/"
+# CMAKE_QML_DIR_IS_ABSOLUTE = "True"
+
+#### Keys ignored in scope 4:.:.:qmlimportscanner.pro:static OR staticlib:
+# CMAKE_STATIC_TYPE = "true"
+
+#### Keys ignored in scope 5:.:.:qmlimportscanner.pro:WIN32:
+# CMAKE_QML_PLUGIN_SUFFIX_DEBUG = "d"
+
+#### Keys ignored in scope 7:.:.:qmlimportscanner.pro:APPLE:
+# CMAKE_QML_PLUGIN_SUFFIX_DEBUG = "_debug"
+
+#### Keys ignored in scope 8:.:.:qmlimportscanner.pro:else:
+# CMAKE_QML_PLUGIN_SUFFIX_DEBUG = <EMPTY>
+
+#### Keys ignored in scope 9:.:.:qmlimportscanner.pro:( QT_FEATURE_debug_and_release OR QT_CONFIG___contains___debug,debug OR release ):
+# CMAKE_DEBUG_TYPE = "debug"
+
+#### Keys ignored in scope 10:.:.:qmlimportscanner.pro:( QT_FEATURE_debug_and_release OR QT_CONFIG___contains___release,debug OR release ):
+# CMAKE_RELEASE_TYPE = "release"
+
+#### Keys ignored in scope 11:.:.:qmlimportscanner.pro:QT_FEATURE_debug_and_release:
+# CMAKE_DEBUG_AND_RELEASE = "TRUE"
+
+#### Keys ignored in scope 12:.:.:qmlimportscanner.pro:else:
+# CMAKE_DEBUG_AND_RELEASE = "FALSE"
+
+#### Keys ignored in scope 13:.:.:qmlimportscanner.pro:QMAKE_HOST.os___equals___Windows:
+# CMAKE_BIN_SUFFIX = ".exe"
+
+#### Keys ignored in scope 14:.:.:qmlimportscanner.pro:prefix_build:
+# INSTALLS = "cmake_build_integration"
+
+#### Keys ignored in scope 15:.:.:qmlimportscanner.pro:else:
+# COPIES = "cmake_build_integration"