aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmllint/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-10-01 12:40:01 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-10-05 14:58:32 +0200
commit767dd738d3de9306062707fe05d32c91ed755da3 (patch)
treeebadcc9809322d5d78ce28f9b82bad1db949f232 /tools/qmllint/CMakeLists.txt
parente7d90fc5268cdca6aa10f422f00ad4a0049ea157 (diff)
Long live libQtQmlCompiler!
Move all the code from tools/shared into src/qmlcompiler and build a static library from it so that we can re-use it in external tools. Change-Id: I7c8d8e59063dc7c711f4072f103a01095e6f5997 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'tools/qmllint/CMakeLists.txt')
-rw-r--r--tools/qmllint/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/tools/qmllint/CMakeLists.txt b/tools/qmllint/CMakeLists.txt
index e9d92cc134..9230d8117b 100644
--- a/tools/qmllint/CMakeLists.txt
+++ b/tools/qmllint/CMakeLists.txt
@@ -9,20 +9,13 @@ qt_add_tool(${target_name}
TARGET_DESCRIPTION "QML Syntax Verifier"
TOOLS_TARGET Qml # special case
SOURCES
- ../shared/importedmembersvisitor.cpp ../shared/importedmembersvisitor.h
- ../shared/metatypes.h
- ../shared/qmljsimporter.cpp ../shared/qmljsimporter.h
- ../shared/qmljstypereader.cpp ../shared/qmljstypereader.h
- ../shared/scopetree.cpp ../shared/scopetree.h
- ../shared/typedescriptionreader.cpp ../shared/typedescriptionreader.h
checkidentifiers.cpp checkidentifiers.h
findwarnings.cpp findwarnings.h
main.cpp
qcoloroutput.cpp qcoloroutput.h
- INCLUDE_DIRECTORIES
- ../shared
PUBLIC_LIBRARIES
Qt::CorePrivate
+ Qt::QmlCompilerPrivate
Qt::QmlDevToolsPrivate
)