aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmllint/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-11-17 11:25:36 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2021-11-23 18:45:06 +0100
commita98747ab6c153e1d361ec64ea616764a71465fa4 (patch)
treef622b3329bc2ef98b5300fef1a38db74533dcc4d /tools/qmllint/CMakeLists.txt
parent608e1a805349b0c76fcd993c43f4f9d808c2d77f (diff)
qmllint: Move most code into a separate library
This is necessary step for both making qmllint viable for use in controls' tst_sanity, as well as for integration with the language server. As an additional upside it allows us to run our tests up to 10x faster. Eventually we want to integrate all of this into qmlcompiler but due to the state of some of the code we will keep qmllint in a separate library as to keep qmlcompiler tidier. Change-Id: Ic057ef0cd4424d28aa05e517d74280a442ec9c5a Reviewed-by: Andrei Golubev <andrei.golubev@qt.io>
Diffstat (limited to 'tools/qmllint/CMakeLists.txt')
-rw-r--r--tools/qmllint/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/tools/qmllint/CMakeLists.txt b/tools/qmllint/CMakeLists.txt
index 4107e10f74..f9127acaa3 100644
--- a/tools/qmllint/CMakeLists.txt
+++ b/tools/qmllint/CMakeLists.txt
@@ -9,15 +9,13 @@ qt_internal_add_tool(${target_name}
TARGET_DESCRIPTION "QML Syntax Verifier"
TOOLS_TARGET Qml # special case
SOURCES
- findwarnings.cpp findwarnings.h
- codegen.cpp codegen.h
- codegenwarninginterface.cpp codegenwarninginterface.h
main.cpp
../shared/qqmltoolingsettings.h
../shared/qqmltoolingsettings.cpp
PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlCompilerPrivate
+ Qt::QmlLintPrivate
)
qt_internal_return_unless_building_tools()