aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmllint/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2020-04-24 15:10:53 +0200
committerMaximilian Goldstein <max.goldstein@qt.io>2020-04-30 18:56:19 +0200
commitac5c765f29106837da717ca7c2e1f266f39d5843 (patch)
treed27d13f5349ac7b217acd14a61ea1eab54f20d89 /tools/qmllint/CMakeLists.txt
parent50cd8cf97aa89a48a9fbaaeb2515e529e66c7d43 (diff)
qmllint: Add flags for toggling warnings
Enables all warnings by default and makes it possible to toggle individual ones using command line flags. Change-Id: Ie55f32f646fd9422313977969f9f00b59ee9ad99 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'tools/qmllint/CMakeLists.txt')
-rw-r--r--tools/qmllint/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/tools/qmllint/CMakeLists.txt b/tools/qmllint/CMakeLists.txt
index d294c2c78e..c6fb5add64 100644
--- a/tools/qmllint/CMakeLists.txt
+++ b/tools/qmllint/CMakeLists.txt
@@ -7,15 +7,15 @@
qt_add_tool(qmllint
TOOLS_TARGET Qml # special case
SOURCES
- checkidentifiers.cpp checkidentifiers.h
../shared/componentversion.cpp ../shared/componentversion.h
- findunqualified.cpp findunqualified.h
- importedmembersvisitor.cpp importedmembersvisitor.h
- main.cpp
../shared/metatypes.h
- qcoloroutput.cpp qcoloroutput.h
../shared/scopetree.cpp ../shared/scopetree.h
../shared/typedescriptionreader.cpp ../shared/typedescriptionreader.h
+ checkidentifiers.cpp checkidentifiers.h
+ findwarnings.cpp findwarnings.h
+ importedmembersvisitor.cpp importedmembersvisitor.h
+ main.cpp
+ qcoloroutput.cpp qcoloroutput.h
INCLUDE_DIRECTORIES
../shared
PUBLIC_LIBRARIES