aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cfd53e07b8..3e82176a60 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,8 +1,10 @@
+# Generated from qtdeclarative.pro.
+
cmake_minimum_required(VERSION 3.15.0)
-project(QtDeclarative
+project(QtDeclarative # special case
VERSION 6.0.0
- DESCRIPTION "Qt Declarative Libraries"
+ DESCRIPTION "Qt Declarative Libraries" # special case
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
@@ -10,7 +12,17 @@ project(QtDeclarative
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network # special case
OPTIONAL_COMPONENTS OpenGL Sql Concurrent Test) # special case
+# special case begin
# export QT6_ADD_QML_MODULE to this project
include(src/qml/Qt6QmlMacros.cmake)
+# special case end
+if(NOT QT_FEATURE_commandlineparser)
+ message(NOTICE "Skipping the build as the condition \"QT_FEATURE_commandlineparser\" is not met.")
+ return()
+endif()
+if(NOT QT_FEATURE_temporaryfile)
+ message(NOTICE "Skipping the build as the condition \"QT_FEATURE_temporaryfile\" is not met.")
+ return()
+endif()
qt_build_repo()