aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/qmlextensionplugins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/qmlextensionplugins/CMakeLists.txt')
-rw-r--r--examples/qml/qmlextensionplugins/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/examples/qml/qmlextensionplugins/CMakeLists.txt b/examples/qml/qmlextensionplugins/CMakeLists.txt
index 333a1e198e..e1c975c735 100644
--- a/examples/qml/qmlextensionplugins/CMakeLists.txt
+++ b/examples/qml/qmlextensionplugins/CMakeLists.txt
@@ -9,7 +9,11 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples/qml/qmlextensionplugins/imports/TimeExample")
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/qml/qmlextensionplugins/imports/TimeExample")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
@@ -42,6 +46,7 @@ set_target_properties(qmlqtimeexampleplugin PROPERTIES
QT_QML_MODULE_INSTALL_QMLTYPES TRUE
QT_QML_MODULE_VERSION 1.0
QT_QML_MODULE_URI TimeExample
+ QT_QMLTYPES_FILENAME imports/TimeExample/plugins.qmltypes
)
qt6_qml_type_registration(qmlqtimeexampleplugin)