aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/qmlextensionplugins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/qmlextensionplugins/CMakeLists.txt')
-rw-r--r--examples/qml/qmlextensionplugins/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/examples/qml/qmlextensionplugins/CMakeLists.txt b/examples/qml/qmlextensionplugins/CMakeLists.txt
index 0a285db409..333a1e198e 100644
--- a/examples/qml/qmlextensionplugins/CMakeLists.txt
+++ b/examples/qml/qmlextensionplugins/CMakeLists.txt
@@ -24,6 +24,7 @@ qt6_add_qml_module(qmlqtimeexampleplugin
target_sources(qmlqtimeexampleplugin PRIVATE
plugin.cpp
+ timemodel.cpp timemodel.h
)
target_link_libraries(qmlqtimeexampleplugin PUBLIC
Qt::Core
@@ -36,3 +37,11 @@ install(TARGETS qmlqtimeexampleplugin
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
+
+set_target_properties(qmlqtimeexampleplugin PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION 1.0
+ QT_QML_MODULE_URI TimeExample
+)
+
+qt6_qml_type_registration(qmlqtimeexampleplugin)