aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/referenceexamples/attached/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/referenceexamples/attached/CMakeLists.txt')
-rw-r--r--examples/qml/referenceexamples/attached/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/examples/qml/referenceexamples/attached/CMakeLists.txt b/examples/qml/referenceexamples/attached/CMakeLists.txt
new file mode 100644
index 0000000000..4d17701aac
--- /dev/null
+++ b/examples/qml/referenceexamples/attached/CMakeLists.txt
@@ -0,0 +1,46 @@
+# Generated from attached.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(attached LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+
+add_qt_gui_executable(attached
+ birthdayparty.cpp birthdayparty.h
+ main.cpp
+ person.cpp person.h
+)
+target_link_libraries(attached PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+)
+
+# Resources:
+set(attached_resource_files
+ "example.qml"
+)
+
+QT6_ADD_RESOURCES(attached "attached"
+ PREFIX
+ "/"
+ FILES
+ ${attached_resource_files}
+)
+
+
+install(TARGETS attached
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)