aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/referenceexamples/binding/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/referenceexamples/binding/CMakeLists.txt')
-rw-r--r--examples/qml/referenceexamples/binding/CMakeLists.txt14
1 files changed, 4 insertions, 10 deletions
diff --git a/examples/qml/referenceexamples/binding/CMakeLists.txt b/examples/qml/referenceexamples/binding/CMakeLists.txt
index 2a2d6575c0..5e33d8a97e 100644
--- a/examples/qml/referenceexamples/binding/CMakeLists.txt
+++ b/examples/qml/referenceexamples/binding/CMakeLists.txt
@@ -1,23 +1,15 @@
-# Generated from binding.pro.
-
cmake_minimum_required(VERSION 3.16)
project(binding LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/qml/referenceexamples/binding")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml)
qt_add_executable(binding
birthdayparty.cpp birthdayparty.h
@@ -25,10 +17,12 @@ qt_add_executable(binding
main.cpp
person.cpp person.h
)
+
set_target_properties(binding PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(binding PUBLIC
Qt::Core
Qt::Gui