aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/referenceexamples/coercion/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/referenceexamples/coercion/CMakeLists.txt')
-rw-r--r--examples/qml/referenceexamples/coercion/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/examples/qml/referenceexamples/coercion/CMakeLists.txt b/examples/qml/referenceexamples/coercion/CMakeLists.txt
index 32b4a0a8ab..46e7c5d5be 100644
--- a/examples/qml/referenceexamples/coercion/CMakeLists.txt
+++ b/examples/qml/referenceexamples/coercion/CMakeLists.txt
@@ -42,3 +42,11 @@ install(TARGETS coercion
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
+
+set_target_properties(coercion PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION 1.0
+ QT_QML_MODULE_URI People
+)
+
+qt6_qml_type_registration(coercion)