aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/referenceexamples/coercion/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/referenceexamples/coercion/CMakeLists.txt')
-rw-r--r--examples/qml/referenceexamples/coercion/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/examples/qml/referenceexamples/coercion/CMakeLists.txt b/examples/qml/referenceexamples/coercion/CMakeLists.txt
new file mode 100644
index 0000000000..57307576a1
--- /dev/null
+++ b/examples/qml/referenceexamples/coercion/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Generated from coercion.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(coercion LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Qml)
+
+add_qt_gui_executable(coercion
+ birthdayparty.cpp birthdayparty.h
+ main.cpp
+ person.cpp person.h
+)
+target_link_libraries(coercion PUBLIC
+ Qt::Core
+ Qt::Qml
+)
+
+# Resources:
+set(coercion_resource_files
+ "example.qml"
+)
+
+QT6_ADD_RESOURCES(coercion "coercion"
+ PREFIX
+ "/"
+ FILES
+ ${coercion_resource_files}
+)
+
+
+install(TARGETS coercion
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)