aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/referenceexamples/methods/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/referenceexamples/methods/CMakeLists.txt')
-rw-r--r--examples/qml/referenceexamples/methods/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/examples/qml/referenceexamples/methods/CMakeLists.txt b/examples/qml/referenceexamples/methods/CMakeLists.txt
index e46e62f586..5812e55eb7 100644
--- a/examples/qml/referenceexamples/methods/CMakeLists.txt
+++ b/examples/qml/referenceexamples/methods/CMakeLists.txt
@@ -42,3 +42,11 @@ install(TARGETS methods
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
+
+set_target_properties(methods PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION 1.0
+ QT_QML_MODULE_URI People
+)
+
+qt6_qml_type_registration(methods)