aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/shell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/shell/CMakeLists.txt')
-rw-r--r--examples/qml/shell/CMakeLists.txt41
1 files changed, 23 insertions, 18 deletions
diff --git a/examples/qml/shell/CMakeLists.txt b/examples/qml/shell/CMakeLists.txt
index 2b3bdd4786..0c376e323a 100644
--- a/examples/qml/shell/CMakeLists.txt
+++ b/examples/qml/shell/CMakeLists.txt
@@ -1,24 +1,29 @@
# Generated from shell.pro.
-#####################################################################
-## shell Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(shell LANGUAGES CXX)
-add_qt_executable(shell
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/qml/shell"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/qml/shell"
- SOURCES
- main.cpp
- PUBLIC_LIBRARIES
- Qt::Qml
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
-## Scopes:
-#####################################################################
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Qml)
-#### Keys ignored in scope 2:.:.:shell.pro:WIN32:
-# CONFIG = "console"
+add_qt_gui_executable(shell
+ main.cpp
+)
+target_link_libraries(shell PUBLIC
+ Qt::Core
+ Qt::Qml
+)
-#### Keys ignored in scope 3:.:.:shell.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
+install(TARGETS shell
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)