aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/shell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/shell/CMakeLists.txt')
-rw-r--r--examples/qml/shell/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/examples/qml/shell/CMakeLists.txt b/examples/qml/shell/CMakeLists.txt
index 5f646ac46e..6c986b7778 100644
--- a/examples/qml/shell/CMakeLists.txt
+++ b/examples/qml/shell/CMakeLists.txt
@@ -21,11 +21,27 @@ find_package(Qt6 COMPONENTS Qml)
qt_add_executable(shell
main.cpp
)
+set_target_properties(shell PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_link_libraries(shell PUBLIC
Qt::Core
Qt::Qml
)
+if(WIN32)
+ set_target_properties(shell PROPERTIES
+ WIN32_EXECUTABLE FALSE
+ )
+endif()
+
+if(APPLE)
+ set_target_properties(shell PROPERTIES
+ MACOSX_BUNDLE FALSE
+ )
+endif()
+
install(TARGETS shell
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"