aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/CMakeLists.txt')
-rw-r--r--examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/CMakeLists.txt b/examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/CMakeLists.txt
index 80429fdf60..eeddbcfc14 100644
--- a/examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/CMakeLists.txt
+++ b/examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/CMakeLists.txt
@@ -10,13 +10,13 @@ endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/qml/tutorials/extending-qml/chapter4-customPropertyTypes")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
-
+#![0]
qt_add_executable(chapter4-customPropertyTypes
main.cpp
piechart.cpp piechart.h
pieslice.cpp pieslice.h
)
-
+#![0]
set_target_properties(chapter4-customPropertyTypes PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
@@ -28,14 +28,14 @@ target_link_libraries(chapter4-customPropertyTypes PUBLIC
Qt::Qml
Qt::Quick
)
-
+#![1]
qt_add_qml_module(chapter4-customPropertyTypes
URI Charts
VERSION 1.0
QML_FILES app.qml
NO_RESOURCE_TARGET_PATH
)
-
+#![1]
install(TARGETS chapter4-customPropertyTypes
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"