aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/CMakeLists.txt')
-rw-r--r--examples/quick/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/quick/CMakeLists.txt b/examples/quick/CMakeLists.txt
index 889b46fa3e..a733e42f1c 100644
--- a/examples/quick/CMakeLists.txt
+++ b/examples/quick/CMakeLists.txt
@@ -38,6 +38,6 @@ endif()
if(TARGET Qt::Widgets)
add_subdirectory(embeddedinwidgets)
endif()
-if(QT_FEATURE_opengles2 OR (QT_FEATURE_opengl AND TARGET Qt::QuickWidgets) OR (QT_FEATURE_opengles3 AND TARGET Qt::Widgets))
+if(TARGET Qt::Widgets AND (QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR QT_FEATURE_opengles3) AND (QT_FEATURE_opengles2 OR QT_FEATURE_opengles3 OR TARGET Qt::QuickWidgets))
add_subdirectory(quickwidgets)
endif()