aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/animation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/animation/CMakeLists.txt')
-rw-r--r--examples/quick/animation/CMakeLists.txt135
1 files changed, 135 insertions, 0 deletions
diff --git a/examples/quick/animation/CMakeLists.txt b/examples/quick/animation/CMakeLists.txt
new file mode 100644
index 0000000000..c4e6d4a3d0
--- /dev/null
+++ b/examples/quick/animation/CMakeLists.txt
@@ -0,0 +1,135 @@
+# Generated from animation.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(animation LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS Qml)
+
+add_qt_gui_executable(animation
+ main.cpp
+)
+target_link_libraries(animation PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set_source_files_properties("../shared/Button.qml"
+ PROPERTIES QT_RESOURCE_ALIAS "Button.qml"
+)
+set_source_files_properties("../shared/CheckBox.qml"
+ PROPERTIES QT_RESOURCE_ALIAS "CheckBox.qml"
+)
+set_source_files_properties("../shared/FlickrRssModel.qml"
+ PROPERTIES QT_RESOURCE_ALIAS "FlickrRssModel.qml"
+)
+set_source_files_properties("../shared/Label.qml"
+ PROPERTIES QT_RESOURCE_ALIAS "Label.qml"
+)
+set_source_files_properties("../shared/LauncherList.qml"
+ PROPERTIES QT_RESOURCE_ALIAS "LauncherList.qml"
+)
+set_source_files_properties("../shared/SimpleLauncherDelegate.qml"
+ PROPERTIES QT_RESOURCE_ALIAS "SimpleLauncherDelegate.qml"
+)
+set_source_files_properties("../shared/Slider.qml"
+ PROPERTIES QT_RESOURCE_ALIAS "Slider.qml"
+)
+set_source_files_properties("../shared/TabSet.qml"
+ PROPERTIES QT_RESOURCE_ALIAS "TabSet.qml"
+)
+set_source_files_properties("../shared/TextField.qml"
+ PROPERTIES QT_RESOURCE_ALIAS "TextField.qml"
+)
+set_source_files_properties("../shared/images/back.png"
+ PROPERTIES QT_RESOURCE_ALIAS "images/back.png"
+)
+set_source_files_properties("../shared/images/checkmark.png"
+ PROPERTIES QT_RESOURCE_ALIAS "images/checkmark.png"
+)
+set_source_files_properties("../shared/images/next.png"
+ PROPERTIES QT_RESOURCE_ALIAS "images/next.png"
+)
+set_source_files_properties("../shared/images/qt-logo.png"
+ PROPERTIES QT_RESOURCE_ALIAS "images/qt-logo.png"
+)
+set_source_files_properties("../shared/images/slider_handle.png"
+ PROPERTIES QT_RESOURCE_ALIAS "images/slider_handle.png"
+)
+set_source_files_properties("../shared/images/tab.png"
+ PROPERTIES QT_RESOURCE_ALIAS "images/tab.png"
+)
+set(shared_resource_files
+ "Button.qml"
+ "CheckBox.qml"
+ "FlickrRssModel.qml"
+ "Label.qml"
+ "LauncherList.qml"
+ "SimpleLauncherDelegate.qml"
+ "Slider.qml"
+ "TabSet.qml"
+ "TextField.qml"
+ "images/back.png"
+ "images/checkmark.png"
+ "images/next.png"
+ "images/qt-logo.png"
+ "images/slider_handle.png"
+ "images/tab.png"
+)
+
+QT6_ADD_RESOURCES(animation "shared"
+ PREFIX
+ "/shared"
+ BASE
+ "../shared"
+ FILES
+ ${shared_resource_files}
+)
+set(animation_resource_files
+ "animation.qml"
+ "basics/animators.qml"
+ "basics/color-animation.qml"
+ "basics/images/face-smile.png"
+ "basics/images/moon.png"
+ "basics/images/shadow.png"
+ "basics/images/star.png"
+ "basics/images/sun.png"
+ "basics/property-animation.qml"
+ "behaviors/SideRect.qml"
+ "behaviors/behavior-example.qml"
+ "behaviors/tvtennis.qml"
+ "behaviors/wigglytext.qml"
+ "easing/easing.qml"
+ "pathanimation/pathanimation.qml"
+ "pathinterpolator/pathinterpolator.qml"
+ "states/qt-logo.png"
+ "states/states.qml"
+ "states/transitions.qml"
+)
+
+QT6_ADD_RESOURCES(animation "animation"
+ PREFIX
+ "/animation"
+ FILES
+ ${animation_resource_files}
+)
+
+
+install(TARGETS animation
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)