aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/customitems/dialcontrol/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/customitems/dialcontrol/CMakeLists.txt')
-rw-r--r--examples/quick/customitems/dialcontrol/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/examples/quick/customitems/dialcontrol/CMakeLists.txt b/examples/quick/customitems/dialcontrol/CMakeLists.txt
new file mode 100644
index 0000000000..b1a9d3c365
--- /dev/null
+++ b/examples/quick/customitems/dialcontrol/CMakeLists.txt
@@ -0,0 +1,53 @@
+# Generated from dialcontrol.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(dialcontrol LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS Qml)
+
+add_qt_gui_executable(dialcontrol
+ main.cpp
+)
+target_link_libraries(dialcontrol PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(dialcontrol_resource_files
+ "content/Dial.qml"
+ "content/QuitButton.qml"
+ "content/background.png"
+ "content/needle.png"
+ "content/needle_shadow.png"
+ "content/overlay.png"
+ "content/quit.png"
+ "dialcontrol.qml"
+)
+
+QT6_ADD_RESOURCES(dialcontrol "dialcontrol"
+ PREFIX
+ "/"
+ FILES
+ ${dialcontrol_resource_files}
+)
+
+
+install(TARGETS dialcontrol
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)