aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/customitems/flipable/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/customitems/flipable/CMakeLists.txt')
-rw-r--r--examples/quick/customitems/flipable/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/examples/quick/customitems/flipable/CMakeLists.txt b/examples/quick/customitems/flipable/CMakeLists.txt
index 469cde10ee..f9b56f201b 100644
--- a/examples/quick/customitems/flipable/CMakeLists.txt
+++ b/examples/quick/customitems/flipable/CMakeLists.txt
@@ -1,21 +1,16 @@
-# Generated from flipable.pro.
-
cmake_minimum_required(VERSION 3.16)
project(flipable LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/customitems/flipable")
-find_package(Qt6 COMPONENTS Core Gui Quick Qml)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
qt_add_executable(flipableexample
WIN32