aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/customitems/painteditem/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/customitems/painteditem/CMakeLists.txt')
-rw-r--r--examples/quick/customitems/painteditem/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/examples/quick/customitems/painteditem/CMakeLists.txt b/examples/quick/customitems/painteditem/CMakeLists.txt
index b036943621..8cf04fdfec 100644
--- a/examples/quick/customitems/painteditem/CMakeLists.txt
+++ b/examples/quick/customitems/painteditem/CMakeLists.txt
@@ -53,3 +53,11 @@ install(TARGETS qmltextballoonplugin
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
+
+set_target_properties(qmltextballoonplugin PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION 1.0
+ QT_QML_MODULE_URI TextBalloonPlugin
+)
+
+qt6_qml_type_registration(qmltextballoonplugin)