aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt')
-rw-r--r--examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt b/examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt
index eb0ef1fd87..fb2bf7568e 100644
--- a/examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt
+++ b/examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt
@@ -1,3 +1,7 @@
+if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
+ message(FATAL_ERROR "TextBalloon should be built as part of the 'painteditem' project, and not in isolation.")
+endif()
+
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/customitems/painteditem/TextBalloon")
qt_add_qml_module(qmltextballoon