aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/imageresponseprovider/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/imageresponseprovider/CMakeLists.txt')
-rw-r--r--examples/quick/imageresponseprovider/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/examples/quick/imageresponseprovider/CMakeLists.txt b/examples/quick/imageresponseprovider/CMakeLists.txt
new file mode 100644
index 0000000000..4b7a33c1b1
--- /dev/null
+++ b/examples/quick/imageresponseprovider/CMakeLists.txt
@@ -0,0 +1,40 @@
+# Generated from imageresponseprovider.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(qmlimageresponseproviderplugin LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/quick/imageresponseprovider/ImageResponseProviderCore")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+qt6_add_qml_module(qmlimageresponseproviderplugin
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/ImageResponseProviderCore"
+ VERSION 1.0
+ URI "ImageResponseProviderCore"
+ INSTALL_LOCATION ${INSTALL_EXAMPLEDIR}
+)
+
+target_sources(qmlimageresponseproviderplugin PRIVATE
+ imageresponseprovider.cpp
+)
+target_link_libraries(qmlimageresponseproviderplugin PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+install(TARGETS qmlimageresponseproviderplugin
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)