aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/pointerhandlers/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/pointerhandlers/CMakeLists.txt')
-rw-r--r--examples/quick/pointerhandlers/CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/examples/quick/pointerhandlers/CMakeLists.txt b/examples/quick/pointerhandlers/CMakeLists.txt
index 17c49848fa..0431092b95 100644
--- a/examples/quick/pointerhandlers/CMakeLists.txt
+++ b/examples/quick/pointerhandlers/CMakeLists.txt
@@ -1,19 +1,15 @@
-# Generated from pointer.pro.
-
cmake_minimum_required(VERSION 3.16)
project(pointerhandlers LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/pointerhandlers")
-find_package(Qt6 COMPONENTS Core Gui Quick Qml Svg)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick Svg)
add_subdirectory("../shared" "shared")
@@ -85,4 +81,5 @@ install(TARGETS pointerhandlersexample
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
+
bundle_shared(pointerhandlersexample)