aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/examples/quick/scenegraph/CMakeLists.txt b/examples/quick/scenegraph/CMakeLists.txt
new file mode 100644
index 0000000000..c18f77b937
--- /dev/null
+++ b/examples/quick/scenegraph/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Generated from scenegraph.pro.
+
+add_subdirectory(customgeometry)
+add_subdirectory(rendernode)
+add_subdirectory(threadedanimation)
+if(QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR QT_FEATURE_opengles3)
+ add_subdirectory(graph)
+ add_subdirectory(simplematerial)
+ add_subdirectory(sgengine)
+ add_subdirectory(textureinsgnode)
+ add_subdirectory(openglunderqml)
+ add_subdirectory(textureinthread)
+ add_subdirectory(twotextureproviders)
+endif()
+if(APPLE_OSX)
+ add_subdirectory(metalunderqml)
+endif()
+if(WIN32)
+ add_subdirectory(d3d11underqml)
+endif()