aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/customgeometry/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/customgeometry/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/customgeometry/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/examples/quick/scenegraph/customgeometry/CMakeLists.txt b/examples/quick/scenegraph/customgeometry/CMakeLists.txt
index 6e4395503c..0f62794a9f 100644
--- a/examples/quick/scenegraph/customgeometry/CMakeLists.txt
+++ b/examples/quick/scenegraph/customgeometry/CMakeLists.txt
@@ -1,7 +1,7 @@
# Generated from customgeometry.pro.
cmake_minimum_required(VERSION 3.14)
-project(customgeometry LANGUAGES CXX)
+project(customgeometry_declarative LANGUAGES CXX) # special case
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -19,11 +19,11 @@ find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Quick)
-add_qt_gui_executable(customgeometry
+add_qt_gui_executable(customgeometry_declarative # special case
beziercurve.cpp beziercurve.h
main.cpp
)
-target_link_libraries(customgeometry PUBLIC
+target_link_libraries(customgeometry_declarative PUBLIC # special case
Qt::Core
Qt::Gui
Qt::Quick
@@ -35,22 +35,22 @@ set(customgeometry_resource_files
"main.qml"
)
-qt6_add_resources(customgeometry "customgeometry"
+qt6_add_resources(customgeometry_declarative "customgeometry" # special case
PREFIX
"/scenegraph/customgeometry"
FILES
${customgeometry_resource_files}
)
-install(TARGETS customgeometry
+install(TARGETS customgeometry_declarative # special case
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
-set_target_properties(customgeometry PROPERTIES
+set_target_properties(customgeometry_declarative PROPERTIES # special case
QT_QML_MODULE_VERSION 1.0
QT_QML_MODULE_URI CustomGeometry
)
-qt6_qml_type_registration(customgeometry)
+qt6_qml_type_registration(customgeometry_declarative) # special case