aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/fboitem/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/fboitem/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/fboitem/CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/examples/quick/scenegraph/fboitem/CMakeLists.txt b/examples/quick/scenegraph/fboitem/CMakeLists.txt
index 1117ef22a9..e788fe5468 100644
--- a/examples/quick/scenegraph/fboitem/CMakeLists.txt
+++ b/examples/quick/scenegraph/fboitem/CMakeLists.txt
@@ -1,7 +1,7 @@
-# Generated from textureinsgnode.pro.
+# Generated from fboitem.pro.
cmake_minimum_required(VERSION 3.14)
-project(textureinsgnode LANGUAGES CXX)
+project(fboitem LANGUAGES CXX)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -9,23 +9,23 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples/quick/scenegraph/textureinsgnode")
+set(INSTALL_EXAMPLEDIR "examples/quick/scenegraph/fboitem")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Qml)
find_package(Qt6 COMPONENTS Quick)
-add_qt_gui_executable(textureinsgnode
+add_qt_gui_executable(fboitem
../shared/logorenderer.cpp ../shared/logorenderer.h
fboinsgrenderer.cpp fboinsgrenderer.h
main.cpp
)
-target_include_directories(textureinsgnode PUBLIC
+target_include_directories(fboitem PUBLIC
../shared
)
-target_link_libraries(textureinsgnode PUBLIC
+target_link_libraries(fboitem PUBLIC
Qt::Core
Qt::Gui
Qt::Qml
@@ -34,18 +34,18 @@ target_link_libraries(textureinsgnode PUBLIC
# Resources:
-set(textureinsgnode_resource_files
+set(fboitem_resource_files
"main.qml"
)
-qt6_add_resources(textureinsgnode "textureinsgnode"
+qt6_add_resources(fboitem "fboitem"
PREFIX
- "/scenegraph/textureinsgnode"
+ "/scenegraph/fboitem"
FILES
- ${textureinsgnode_resource_files}
+ ${fboitem_resource_files}
)
-install(TARGETS textureinsgnode
+install(TARGETS fboitem
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"