aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/fboitem/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/fboitem/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/fboitem/CMakeLists.txt62
1 files changed, 62 insertions, 0 deletions
diff --git a/examples/quick/scenegraph/fboitem/CMakeLists.txt b/examples/quick/scenegraph/fboitem/CMakeLists.txt
new file mode 100644
index 0000000000..ba4b487415
--- /dev/null
+++ b/examples/quick/scenegraph/fboitem/CMakeLists.txt
@@ -0,0 +1,62 @@
+# Generated from fboitem.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(fboitem LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/quick/scenegraph/fboitem")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+add_qt_gui_executable(fboitem
+ ../shared/logorenderer.cpp ../shared/logorenderer.h
+ fboinsgrenderer.cpp fboinsgrenderer.h
+ main.cpp
+)
+target_include_directories(fboitem PUBLIC
+ ../shared
+)
+
+target_link_libraries(fboitem PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+
+# Resources:
+set(fboitem_resource_files
+ "main.qml"
+ "shaders/+qsb/checker.frag"
+ "shaders/checker.frag"
+)
+
+qt6_add_resources(fboitem "fboitem"
+ PREFIX
+ "/scenegraph/fboitem"
+ FILES
+ ${fboitem_resource_files}
+)
+
+install(TARGETS fboitem
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)
+
+set_target_properties(fboitem PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION 1.0
+ QT_QML_MODULE_URI SceneGraphRendering
+)
+
+qt6_qml_type_registration(fboitem)