aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/metaltextureimport/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/metaltextureimport/CMakeLists.txt64
1 files changed, 64 insertions, 0 deletions
diff --git a/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt b/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
new file mode 100644
index 0000000000..d84885f4cf
--- /dev/null
+++ b/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
@@ -0,0 +1,64 @@
+# Generated from metaltextureimport.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(metaltextureimport LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/quick/scenegraph/metaltextureimport")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+add_qt_gui_executable(metaltextureimport
+ main.cpp
+ metaltextureimport.h metaltextureimport.mm
+)
+target_link_libraries(metaltextureimport PUBLIC
+ "-framework Metal"
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+
+# Resources:
+set(metaltextureimport_resource_files
+ "main.qml"
+ "squircle.frag"
+ "squircle.vert"
+)
+
+qt6_add_resources(metaltextureimport "metaltextureimport"
+ PREFIX
+ "/scenegraph/metaltextureimport"
+ FILES
+ ${metaltextureimport_resource_files}
+)
+
+if(APPLE_OSX)
+ target_link_libraries(metaltextureimport PUBLIC
+ "-framework AppKit"
+ )
+endif()
+
+install(TARGETS metaltextureimport
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)
+
+set_target_properties(metaltextureimport PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION 1.0
+ QT_QML_MODULE_URI MetalTextureImport
+)
+
+qt6_qml_type_registration(metaltextureimport)