aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/metaltextureimport/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/metaltextureimport/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt b/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
index eb3740f6ef..68451e292c 100644
--- a/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
+++ b/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
@@ -1,29 +1,21 @@
-# Generated from metaltextureimport.pro.
-
cmake_minimum_required(VERSION 3.16)
project(metaltextureimport LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/scenegraph/metaltextureimport")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
-find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
qt_add_executable(metaltextureimport
main.cpp
metaltextureimport.h metaltextureimport.mm
)
+
set_target_properties(metaltextureimport PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
@@ -31,6 +23,7 @@ set_target_properties(metaltextureimport PROPERTIES
# Prevent name clash with build subdirectory on case-insensitive file systems
OUTPUT_NAME metaltextureimportapp
)
+
target_link_libraries(metaltextureimport PUBLIC
"-framework Metal"
Qt::Core