aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/metalunderqml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/metalunderqml/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/metalunderqml/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/examples/quick/scenegraph/metalunderqml/CMakeLists.txt b/examples/quick/scenegraph/metalunderqml/CMakeLists.txt
index 6f61cdd727..60bb00aa37 100644
--- a/examples/quick/scenegraph/metalunderqml/CMakeLists.txt
+++ b/examples/quick/scenegraph/metalunderqml/CMakeLists.txt
@@ -21,7 +21,6 @@ add_qt_gui_executable(metalunderqml
metalsquircle.h metalsquircle.mm
)
target_link_libraries(metalunderqml PUBLIC
- "-framework AppKit"
"-framework Metal"
Qt::Core
Qt::Gui
@@ -44,6 +43,12 @@ qt6_add_resources(metalunderqml "metalunderqml"
${metalunderqml_resource_files}
)
+if(APPLE_OSX)
+ target_link_libraries(metalunderqml PUBLIC
+ "-framework AppKit"
+ )
+endif()
+
install(TARGETS metalunderqml
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"