aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/metalunderqml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/metalunderqml/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/metalunderqml/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/examples/quick/scenegraph/metalunderqml/CMakeLists.txt b/examples/quick/scenegraph/metalunderqml/CMakeLists.txt
index 9702987176..6f61cdd727 100644
--- a/examples/quick/scenegraph/metalunderqml/CMakeLists.txt
+++ b/examples/quick/scenegraph/metalunderqml/CMakeLists.txt
@@ -9,7 +9,7 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/quick/scenegraph/metalunderqml")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
@@ -21,14 +21,15 @@ add_qt_gui_executable(metalunderqml
metalsquircle.h metalsquircle.mm
)
target_link_libraries(metalunderqml PUBLIC
- ${FWAppKit}
- ${FWMetal}
+ "-framework AppKit"
+ "-framework Metal"
Qt::Core
Qt::Gui
Qt::Qml
Qt::Quick
)
+
# Resources:
set(metalunderqml_resource_files
"main.qml"
@@ -43,7 +44,6 @@ qt6_add_resources(metalunderqml "metalunderqml"
${metalunderqml_resource_files}
)
-
install(TARGETS metalunderqml
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"