aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/openglunderqml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/openglunderqml/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/openglunderqml/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/examples/quick/scenegraph/openglunderqml/CMakeLists.txt b/examples/quick/scenegraph/openglunderqml/CMakeLists.txt
new file mode 100644
index 0000000000..af8aa49a4d
--- /dev/null
+++ b/examples/quick/scenegraph/openglunderqml/CMakeLists.txt
@@ -0,0 +1,47 @@
+# Generated from openglunderqml.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(openglunderqml LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+add_qt_gui_executable(openglunderqml
+ main.cpp
+ squircle.cpp squircle.h
+)
+target_link_libraries(openglunderqml PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(openglunderqml_resource_files
+ "main.qml"
+)
+
+QT6_ADD_RESOURCES(openglunderqml "openglunderqml"
+ PREFIX
+ "/scenegraph/openglunderqml"
+ FILES
+ ${openglunderqml_resource_files}
+)
+
+
+install(TARGETS openglunderqml
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)