aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/textureinthread/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/textureinthread/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/textureinthread/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/examples/quick/scenegraph/textureinthread/CMakeLists.txt b/examples/quick/scenegraph/textureinthread/CMakeLists.txt
index 12579b3456..b409f230af 100644
--- a/examples/quick/scenegraph/textureinthread/CMakeLists.txt
+++ b/examples/quick/scenegraph/textureinthread/CMakeLists.txt
@@ -9,7 +9,7 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/quick/scenegraph/textureinthread")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
@@ -23,16 +23,19 @@ add_qt_gui_executable(textureinthread
target_include_directories(textureinthread PUBLIC
../shared
)
+
target_link_libraries(textureinthread PRIVATE
Qt::CorePrivate
Qt::GuiPrivate
)
+
target_link_libraries(textureinthread PUBLIC
Qt::Core
Qt::Gui
Qt::Quick
)
+
# Resources:
set(textureinthread_resource_files
"error.qml"
@@ -46,7 +49,6 @@ qt6_add_resources(textureinthread "textureinthread"
${textureinthread_resource_files}
)
-
install(TARGETS textureinthread
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"