aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/threadedanimation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/threadedanimation/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/threadedanimation/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/examples/quick/scenegraph/threadedanimation/CMakeLists.txt b/examples/quick/scenegraph/threadedanimation/CMakeLists.txt
new file mode 100644
index 0000000000..ef3ca17b93
--- /dev/null
+++ b/examples/quick/scenegraph/threadedanimation/CMakeLists.txt
@@ -0,0 +1,48 @@
+# Generated from threadedanimation.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(threadedanimation LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+add_qt_gui_executable(threadedanimation
+ main.cpp
+ spinner.cpp spinner.h
+)
+target_link_libraries(threadedanimation PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(threadedanimation_resource_files
+ "main.qml"
+ "spinner.png"
+)
+
+QT6_ADD_RESOURCES(threadedanimation "threadedanimation"
+ PREFIX
+ "/scenegraph/threadedanimation"
+ FILES
+ ${threadedanimation_resource_files}
+)
+
+
+install(TARGETS threadedanimation
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)